Emerald Editor Discussion
May 24, 2017, 10:42:09 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: using capture console and input, appends garbage  (Read 4316 times)
0 Members and 1 Guest are viewing this topic.
kefurd06
Prospector
*
Posts: 3


« on: October 04, 2007, 08:39:36 pm »

i hope that subject wasn't too confusing and that this topic hasn't already been covered.

I am compiling java source, executing it, and using the capture output option for I/O. however i find that (probably relating to MS Vista) when i send input back to my program, sometimes the input returns clean and other times garbage is appended to the end. in the 3.7 version of CE, i usually just get one strange character at the end of my input. in the latest beta, i'm getting a string of characters, some normal, some not. this only happens sometimes and i haven't figured out exactly what causes it to happen. i'm using number inputs. for example, i enter the number 10 and press enter and CE actually returns as my input "10fvGPOS─´" which of course generates an error.

i've got a few media items to demonstrate what's going on. Any feedback would be greatly appreciated.

Flash video of the error
http://www.screencast.com/users/treebars/folders/Jing/media/d1719ff8-7339-40a5-a9d6-089052f3ea1a
Images of the error
http://screencast.com/t/Wek99Xeam
« Last Edit: October 04, 2007, 08:46:21 pm by kefurd06 » Logged
pn8830
Global Moderator
Jeweller
*****
Posts: 252



« Reply #1 on: October 05, 2007, 04:45:17 pm »

Did you try to run it from command line rather then from user tools?
PN

2 mods: please move to Crimson Support.
Logged

Entities should not be multiplied beyond necessity
kefurd06
Prospector
*
Posts: 3


« Reply #2 on: October 07, 2007, 09:51:30 pm »

Did you try to run it from command line rather then from user tools?
PN

2 mods: please move to Crimson Support.

yes. of course taking ce out of the equation solves the problem of CE adding garbage to the input

i have reposted this in crimson support. sorry for the messup.
http://forum.emeraldeditor.com/index.php?topic=444.msg3216#msg3216
« Last Edit: October 07, 2007, 09:55:32 pm by kefurd06 » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.143 seconds with 18 queries.