Emerald Editor Discussion
May 25, 2017, 11:31:45 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: wxWidgets Version  (Read 5456 times)
0 Members and 1 Guest are viewing this topic.
daemon
Developers
Gem Cutter
***
Posts: 107


WWW
« on: June 01, 2006, 05:59:32 am »

In wxStEdit, there's some backwards-compatibility code for versions less than 2.6.0. I think that we should make sure that everybody develops using the same widgets version. Currently, the latest stable is 2.6.3.

If this seems good to everybody, I'll go ahead and remove all the legacy code Smiley.
Logged
Arantor
Site Administrator
Administrator
Master Jeweller
*****
Posts: 618



« Reply #1 on: June 01, 2006, 05:24:36 pm »

No real issues here, especially since we're aiming at a static build.

Upgrading wxWidgets is not a major hassle for anyone building from source anyway (*flinching before the flames start*) so I don't have any problems with it.
Logged

"Cleverly disguised as a responsible adult!"
daemon
Developers
Gem Cutter
***
Posts: 107


WWW
« Reply #2 on: June 02, 2006, 12:30:13 am »

I didn't think it would be a serious issue, but just making sure we're all on the same page.
Logged
awmyhr
Senior Miner
***
Posts: 95

Maintainer of Obscure and Unused Ports


WWW
« Reply #3 on: July 18, 2006, 09:20:19 pm »

FYI: In messing around with removing bits and peices of wxWidgets, I tried --disable-compat24.  However, emerald build failed with following error:

g++ -c -o emerald_stedit.o -DNDEBUG -O2  -I../solaris/vendor//lib/wx/include/gtk2-unicode-release-static-2.6 -I../solaris/vendor//include/wx-2.6  -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DNO_GCC_PRAGMA  -MTemerald_stedit.o -MFemerald_stedit.o.d -MD stedit.cpp
stedit.cpp: In member function 'bool wxSTEditor::ShowPrintSetupDialog()':
stedit.cpp:3644: error: 'class wxPrintDialogData' has no member named 'SetSetupDialog'

since we are removing such legacy code, I attempted to file this as a bug, but the bug tracker has no product/version info set up, so I cannot submit...
Logged

-->>  This Space 4 Rent  <<--
awmyhr
Senior Miner
***
Posts: 95

Maintainer of Obscure and Unused Ports


WWW
« Reply #4 on: July 19, 2006, 04:44:13 pm »

Okay, nevermind.  Seems I was a little unskillful in that I was using a slightly older code base (the system I'm using is not able to access the repository directly due to a firewall, I was using an old tarball I downloaded from home a day or two before daemon's 2.4less update...)
Logged

-->>  This Space 4 Rent  <<--
Arantor
Site Administrator
Administrator
Master Jeweller
*****
Posts: 618



« Reply #5 on: July 21, 2006, 11:08:03 pm »

It's in the bug tracker now, I've opened and closed it but you should be able to as well - if you find anything else.
Logged

"Cleverly disguised as a responsible adult!"
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.13 seconds with 18 queries.